PCNotfallhilfe

Tipps und Hilfe aus der IT-Welt von A wie Android bis Z wie Zuse

Excel Anzahl verschiedener Einträge anzeigen

| Keine Kommentare

Wenn man innerhalb einer Spalte verschiedene Einträge hat, ist es schwer, mit einem Blick zu erkennen, um wie viele verschiedene Einträge es sich handelt. Jetzt könnte man nach dieser Spalte sortieren, die doppelten markieren, filtern und anschliessend über den „Rest“ die Anzahl ermitteln. Oder man erstellt mit wenigen Klicks eine Pivottabelle. Einfacher geht es jedoch mit einer Formel.
Wir stellen uns vor, in Spalte „A“ stehen die verschiedenen (und doppelten) Einträge ab Zeile 2 bis Zeile 100. In Zeile A1 steht für gewöhnlich die Überschrift.
Jetzt geben wir eine Formel, in irgendeine andere Zelle (wo auch immer wir die Anzahl verschiedener Einträge angezeigt haben wollen) ein. Die Formel lautet:
=SUMME(1/ZÄHLENWENN(A2:A100;A2:A100))
Nachdem sie diese Formel eingegeben haben und auf Enter gedrückt haben, erscheint eine Fehlermeldung in der Zelle. Es handelt sich hierbei um eine Matrixformel. Das Ergebnis einer Matrixformel erhält man nur, wenn man die STRG+Umschalttaste gedrückt hält und dann die Entertaste drückt. Nun erhält man die Zahl, die anzeigt, wieviele verschieden Einträge der Bereich A2 bis A100 enthält.

Schreibe einen Kommentar

Pflichtfelder sind mit * markiert.