SVerweis optimieren mit der Funktion ISTFEHLER

In verschiedenen Beiträgen habe ich mich generell dem SVerweis (vlookup) gewidmet. Die meisten Beispiele sind dann natürlich so konstruiert, das man etwas mit der SVerweis-Funktion findet.

Aber was tun, wenn man Fehlermeldungen erhält, wie #NV, weil das Suchkriterium nicht in der anderen Tabelle/Matrix vorkommt?

2014-10-08 21_46_54-sverweis_vlookup

 

 

 

 

 

 

In vielen Fällen möchte man an dieser Stelle entweder gar nichts, einen bestimmten Zahlenwert oder einen Text hinterlegen.
Einen besonderen Fall habe ich weiter unten beschrieben, bei dem zwei unterschiedliche Tabellen gleichzeitig in einer Formel abgefragt werden können (klick)

OK, die Formel oder Syntax der SVerweis Funktion:

SVERWEIS(A5;Tabelle2!A5:B13;2;0)

wirft hier einen Fehler aus, weil das Suchkriterium nicht in der Suchmatrix enthalten ist. Excel stellt einige IST-Funktionen zur Verfügung, die wir uns zu Nutze machen können.

2014-10-08 21_57_19-ist-funktionen

 

 

 

 

 

 

 

Für diesen speziellen Fall wählen wir die IST-Funktion –> ISTFEHLER in Kombination mit der WENN-Funktion.

Die WENN-Funktion hat folgende Syntax: WENN – DANN – SONST

Wir können das ausnutzen und nach dem Schema vorgehen:

WENN es einen FEHLER gibt, DANN gib mir einen Text zurück, SONST nutze den SVERWEIS.

Wir gehen folgendermaßen vor:

  1. Wir kopieren die eigentliche SVerweis Funktion SVERWEIS(A5;Tabelle2!A5:B13;2;0) mit STRG+C in die Zwischenablage
  2. Dann schreiben wir direkt hinter dem Gleichheitszeichen und vor der SVerweis-Funktion: WENN(ISTFEHLER(
  3. gehen ans ENDE der SVerweis-Funktion und schließen diese mit einem ) ab. Zwischenstand: =WENN(ISTFEHLER(SVERWEIS(A5;Tabelle2!A5:B13;2;0))
  4. Als nächstes formulieren wir den DANN-Fall, starten mit einem Semikolon und dem Text, der angezeigt werden soll, wenn ein Fehler auftritt:
    Zwischenstand: =WENN(ISTFEHLER(SVERWEIS(A5;Tabelle2!A5:B13;2;0));”Dein Text”
  5. Zum Schluss noch der SONST-Fall und wir starten wieder mit einem Semikolon und fügen dann die vorher kopierte SVerweis Funktion ein und schließen mit einer Klammer ab.
  6. Endstand der Formel: =WENN(ISTFEHLER(SVERWEIS(A5;Tabelle2!A5:B13;2;0));”Dein Text”;SVERWEIS(A5;Tabelle2!A5:B13;2;0))

2014-10-08 22_13_51-Microsoft Excel - sverweis.xls [Kompatibilitätsmodus]

 

 

 

An der Stelle in der Formel

=WENN(ISTFEHLER(SVERWEIS(A5;Tabelle2!A5:B13;2;0));“Dein Text”;SVERWEIS(A5;Tabelle2!A5:B13;2;0))

kann man seinen Wünschen freien Lauf lassen.

Ein paar Beispiele für ISTFEHLER mit WENN und SVerweis:

  • Wenn man NICHTS ausgeben lassen will:
    • =WENN(ISTFEHLER(SVERWEIS(A5;Tabelle2!A5:B13;2;0));“”;SVERWEIS(A5;…..
  • Wenn man eine Null als Zahl ausgeben lassen will:
    • =WENN(ISTFEHLER(SVERWEIS(A5;Tabelle2!A5:B13;2;0));0;SVERWEIS(A5;……
  • usw…..

Einen ganz speziellen Fall möchte ich noch erwähnen:

Wir nehmen an, es sollen ZWEI unterschiedliche Tabellen, entweder:

  • aus dem gleichen Arbeitsblatt
  • aus einem anderen Arbeitsblatt innerhalb der gleichen Datei oder
  • aus einer anderen Tabelle einer anderen Datei abgefragt werden.

Die sprachliche Syntax würde dann lauten:

WENN – ISTFEHLER – SVerweis 1 – DANN – SVERWEIS 2 – SONST – SVerweis 1

Beispiel:

=WENN(ISTFEHLER(SVERWEIS(A5;Tabelle2!A5:B13;2;0));SVERWEIS(A5;Tabelle3!A1:B100;1;0); SVERWEIS(A5;Tabelle2!A5:B13;2;0))

(zurück)

Sollten noch Fragen bei Euch auftauchen oder Anmerkungen, freue ich mich über Eure Kommentare

LG John